Erstellen eines Werkzeuges für das Zeichnen von Vektoren an bestimmten Stellen

Aus Geogebra Rheinland-Pfalz
Wechseln zu: Navigation, Suche
Kurzinfo
Aufgabe für Fortgeschrittene Nutzer
Dies ist eine Aufgabe für fortgeschrittene GeoGebra-Nutzer. ... mehr davon hier.
Birgit Lachner.
Diese Seite wurde von Birgit Lachner erstellt.

HINWEIS: Zur Bearbeitung dieser Aufgabe benötigen Sie die Version 5.0 von GeoGebra, die zur Zeit erst als Beta-Version verfügbar ist. Das bedeutet, dass die Version noch in Entwicklung ist. Die benötigten Fähigkeiten sind aber vorhanden.

Inhaltsverzeichnis

Aufgabenstellung

GeoGebra bietet für das Zeichnen von Vektoren mit dem Textbefehl Vektor[] zwei Varianten an:

  • Vektor[Punkt] ... zum Zeichnen des Ortsvektors des angegebenen Punktes, also vom Ursprung zum Punkt hin.
  • Vektor[Anfangspunkt,Endpunkt] ... zum Zeichnen eines Vektors zwischen den zwei gegebenen Punkten.

In den Büchern gibt es aber öfters Aufgaben, für die, wenn man sie in GeoGebra umsetzen will, man eine Möglichkeit bräuchte, von einem Punkt aus einen bestimmten Vektor zu zeichnen. Das kann man natürlich auch mit Hilfe der Variante Vektor[Anfangspunkt,Endpunkt] machen, aber wenn man sich nur auf die Bestimmung des fehlenden Vektors konzentrieren will, macht ein Werkzeug VektorVon[Startpunkt,Vektor] Sinn.

Wie man das Werkzeug nennt oder in welcher Reihenfolge man die Werte "Punkt" und "Vektor" eingeben soll, kann natürlich jeder selber bestimmen. In dieser Anleitung soll aber nun ein Werkzeug VektorVon[Startpunkt,Vektor] erstellt werden, das einen Vektor mit den angegebenen Koordinaten (auch wenn sie berechnet werden) vom Startpunkt aus zeichnet.

Anleitung

Im GeoGebra-Handbuch-Wiki finden Sie Informationen zum Erstellen von eigenen Werkzeugen und dem Umgang damit auf dieser und dieser Seite.

Schritt Was ? Wo? Wie?
1 Grafik-Ansicht schließen, 3D-Ansicht anzeigen lassen und in das Hauptfenster integrieren. Menü Ansicht Im Menü Ansicht in beliebiger Reihenfolge "Grafik" und "Grafik 3D" anwählen. Man sollte dann noch die Algebra- und die 3D-Ansicht auf eine sinnvolle Größe ändern, indem man die Linien zwischen den beiden Ansichten verschiebt.
2 Einen beliebigen Punkt einzeichnen. Eingabezeile oder Werkzeug Neuer Punkt Zum Beispiel in der Eingabezeile eingeben: A=(1,1,1)
3 Einen freien Vektor angeben. Eingabezeile Zum Beispiel in der Eingabezeile eingeben: a=(1,2,3)
3 Den Vektor einzeichnen, der als Ergebnis des Werkzeuges herauskommen soll. Eingabezeile In der Eingabezeile eingeben: v=Vektor[A,A+a] Achtung! Kleines "v"
4 Dialog zum Erzeugen eines neuen Werkzeuges aufrufen. Menü Werkzeuge Wählen Sie im Menü Werkzeuge den Punkt Neues Werkzeug erstellen.
5 Ausgabe-Objekt des Werkzeuges aus der Liste auswählen Dialog Neues Werkzeug erstellen - Tab Ausgabe Objekte Im zuerst vorne liegenden Tab Ausgabe Objekte den Vektor v in der am Anfang noch leeren Ausklappbox (Combo-Box) auswählen.
6 Eingabe-Objekt des Werkzeuges kontrollieren Dialog Neues Werkzeug erstellen - Tab Ausgabe Objekte Den Weiter-Knopf unten im Dialog anklicken ober oben den Tab Ausgabe Objekte anwählen. Dort müssten der Punkt A und der Vektor a (bei der Benennung wie vorgegeben) ausgewählt worden sein. Beachten Sie auch die Reihenfolge! Oben sollte der Punkt stehen. Ist das nicht der Fall, kann dies mit den Hoch/Runter-Pfeil-Knöpfen verändert werden.
7 Name des Werkzeugs und eventuell Hilfen angeben Dialog Neues Werkzeug erstellen - Tab Name & Symbol Den Weiter-Knopf unten im Dialog anklicken ober oben den Tab Name & Symbol anwählen. In den Feldern Werkzeug Name und Befehlsname den Text VektorVon eintragen. Das Hilfe-Feld kann man leer lassen und man muss auch kein eigenes Symbol zeichnen und verwenden.
8 Werkzeug erzeugen und ausprobieren Dialog Neues Werkzeug erstellen Klicken Sie auf den Knopf Fertigstellen. Es sollte eine Erfolgsmeldung erscheinen und ein neuer Werkzeug-Knopf in der Werkzeug-Leiste ergänzt werden. Zeichnen Sie weitere Punkte und Vektoren und probieren in der Eingabezeile VektorVon[Punkt, Vektor] aus. Beim Tippen sollte der Befehl VektorVon auch als Auswahl angeboten werden.

HINWEIS: Zum Erstellen von Werkzeugen braucht man unabhängige Vektoren. Dabei spielt keine Rolle wo diese liegen. Hätte man einen Vektor, der zwischen zwei Punkten gezeichnet ist, so ist er von diesen zwei Punkten abhängig. Dann müssten auch für das Werkzeug zwei Punkte angegeben werden anstatt des Vektors.

Download des Werkzeuges

... auf GeoGebraTube: Werkzeug "VektorVon"

Anwendung in der Schule

Als Beispiele für die Anwendung sei auf die folgenden Aufgaben verwiesen: